Lng options not working

Hi, I am new to the lightning js platform and installed the Lightning-SDK and CLI. The only issue i have encountered so far is i can’t use the lng options like lng build. The error is “Please make sure you are running the command in the Application directory”. The code is in the same directory and i have also created the new app by using “lng create” commands and that was working fine only issue is with the sample code provided.
As suggested i have also moved the working code to C drive but same error occured.
“lng create” and “lng options” are working but not “lng build and serve commands”.
Any suggestions?

1 Like

I haven’t used Lighting on Windows but not sure if you installed Lightning globally instead of running your instance from your repository’s node_modules?

Hi! From the looks of your screenshot you’re trying to execute the build command in the CLI source folder. You should execute this command in the app folder created via the lng create command

1 Like

Hi, Naveen.

has this been fixed for you?

Have you tried uninstalling the Lightning package and reinstalling?

Have you had a working application before this or is this your first one?

Happy to discuss the process with you.

Hi Jacob,
The other projects are working fine. I have downloaded this sample project “GitHub - rdkcentral/Lightning: Lightning - The WPE UI Framework for developing Apps and UX” for learning purpose. The issue still persist. I am not able to use lng commands in this project.

Hello Naveen,

The lng commands (i.e the Lightning CLI) assume you are using the Lightning-SDK (LightningJS.io - Documentation). The lng create command automatically create a project based on the Lightning-SDK.

The Lightning-CLI doesn’t work with a barebones Lightning Core project (which is the one you linked to)