Regarding lighting application on tizen operating system(Samsung Tv)

Hello Team ,
I am trying to run my Lightning js application on samsung tv(emulator) , Operating system(Tizen app) here, i am unable to hit the api’s that is why there is no any other screen showing after the entering od login credentials on

login page.I am attaching the screenshot of the error , Kindly help me with this.

Hi Shruti,

This has very little to do with Lightning, and all with Network Requests.

Please make sure you understand:

Now I’d suggest the following:

  • Test if the same API call from the App works from another device (e.g. your laptop). If it doesn’t, something is likely wrong with the API, URL or server
  • Since it throws a URL scheme error, something is likely wrong in how you construct the URL or provide the URL to the XML Http Request API.
  • If it does work from your laptop but doesn’t work from the box, check the certificate and see if that is still valid. Make sure your device is updated too so it has the latest root certificates installed.
  • Create a standalone test app that just calls the URL, see if the problem persists.

Also be sure to remove string template literals in the way you construct the url, mak to see if that causes the issue, some older browsers have issues with that.

1 Like

Actually , when i am using or running the same api or server url on the lightning js on google chrome that is working fine with the help of same api but when i m trying to run the same api or server url on tizen emulator then , it is working not fine and giving the error . My server certification is still valid or working fine .

even i have tested the same url or api on the postman app and there also the same api or server url working fine.

Important things to note:

  1. This has nothing to do with Lightning. Its all about Web + Networking
  2. When running on the simulator, you’re running the web app locally using localhost - so all API requests are Cross domain and you need to make sure CORS is setup correctly:
    Cross-Origin Resource Sharing (CORS) - HTTP | MDN
  3. The network tab will provide additional info - you should see an OPTIONS request happening.
  4. It looks like --disable-security flag is set which should turn off CORS. Though that may not be working, hence you’ll need to research CORS.
1 Like